Xephem packages for Debian/Ubuntu.

Debian jessie/stretch/buster and Ubuntu trusty/xenial/bionic (and other?) users add to your /etc/apt/sources.list:
  deb [ trusted=yes ] http://e2rd.piekielko.pl/debian $your_dist$ non-free
 i.e: deb [ trusted=yes ] http://e2rd.piekielko.pl/debian buster non-free

<oldVersion>
i386, amd64 or armhf -arch users add to your /etc/apt/sources.list:

  deb http://e2rd.piekielko.pl/debian binary-$(ARCH)/
or/and (if you want to do dpkg-buildpackage by yourself)
  deb-src http://e2rd.piekielko.pl/debian binary-$(ARCH)/
</oldVersion>

then install as usually (apt-get update; apt-get install xephem)
(of course you can install it manually: download .deb file from binary-$arch directory and run: 
  dpkg -i [filename.deb])

If you want compile yourself:
- add to /etc/apt/sources.list
  deb-src [ trusted=yes ] http://e2rd.piekielko.pl/debian $your_dist$ non-free
- run:
 apt install dpkg-dev debhelper libmotif-dev libice-dev libsm-dev libx11-dev libxt-dev libssl-dev
 apt source xephem
 cd xephem-3.7.7/
 dpkg-buildpackage
- install package: dpkg -i [../filename.deb]


package xephem-catalogs contains 37 (66MB) different catalogs (hip, sao, tycho2 etc.) for xephem collected by me some time ago. due to "free" xephem (2016-11-01) package xephem-catalogs contains 343MB different catalgos (hip, sao, tycho2 etc.) for xephem (from disk 1) gsc1.1.tar.gz is a GSC 1.1 (?) - ready to use in xephem (obsolete) - use gsc2.2 (up to +18.5mag) from xephem site (only 1.3GB)
17-11-2018 New debian version - 3.7.7-4 - Added ssl and vsop patches from user/contrib. separate packages for debian < v.9 and v.9+ (Ubuntu < 18.04 >= ) Compiled on Jessie (libssl-1.0.0) and Stretch (libssl-1.1) contact: sanlu [at] pkim . org
      Name                                   Last modified      Size  Description
Parent Directory - binary-amd64/ 2018-11-16 17:01 - binary-armhf/ 2016-11-10 22:35 - binary-i386/ 2018-11-16 16:31 - dists/ 2018-11-17 00:31 - jessie/ 2018-11-16 23:23 - rc/ 2011-08-11 11:16 - corrida_0.96.11-1.diff.gz 2008-04-14 00:21 11K corrida_0.96.11-1.dsc 2008-04-14 00:21 376 corrida_0.96.11.orig.tar.gz 2008-04-14 00:20 1.9M corrida_0.96.15-1.diff.gz 2009-07-15 16:27 11K corrida_0.96.15-1.dsc 2009-07-15 16:27 764 corrida_0.96.15.orig.tar.gz 2009-07-15 16:16 1.9M corrida_0.96.16-1.diff.gz 2009-09-09 16:27 11K corrida_0.96.16-1.dsc 2009-09-09 16:27 764 corrida_0.96.16.orig.tar.gz 2009-09-09 16:27 1.9M gsc1.1.tar.gz 2016-06-26 21:41 138M makexe2.tar.gz 2000-12-27 21:08 4.6K xephem-3.7.6.tar.gz 2013-01-20 18:02 17M xephem-3.7.7.tar.gz 2015-08-10 04:53 17M xephem-catalogs_0.0.20070214-1_all.deb 2007-02-16 11:23 39M xephem-catalogs_0.0.20161106-1_all.deb 2016-11-10 22:32 103M xephem_3.7.3-2.diff.gz 2008-04-12 22:54 9.7K xephem_3.7.3-2.dsc 2008-04-12 22:54 681 xephem_3.7.3.orig.tar.gz 2008-04-11 22:59 21M xephem_3.7.4-1.diff.gz 2009-07-15 15:33 9.8K xephem_3.7.4-1.dsc 2009-07-15 15:33 1.0K xephem_3.7.4.orig.tar.gz 2009-07-04 09:24 21M xephem_3.7.5-1.diff.gz 2011-08-11 11:14 10K xephem_3.7.5-1.dsc 2011-08-11 11:14 1.0K xephem_3.7.5.orig.tar.gz 2011-08-11 11:14 18M xephem_3.7.6-1.debian.tar.gz 2013-01-21 22:47 13K xephem_3.7.6-1.dsc 2013-01-21 22:47 1.0K xephem_3.7.6.orig.tar.gz 2013-01-20 18:02 17M xephem_3.7.7-1.debian.tar.gz 2015-08-19 23:21 12K xephem_3.7.7-1.dsc 2015-08-19 23:21 1.0K xephem_3.7.7-2.debian.tar.gz 2015-08-23 00:19 13K xephem_3.7.7-2.dsc 2015-08-23 00:20 1.1K xephem_3.7.7-3.debian.tar.xz 2016-11-10 22:27 242K xephem_3.7.7-3.dsc 2016-11-10 22:27 1.1K xephem_3.7.7-4.debian.tar.xz 2018-11-16 15:33 719K xephem_3.7.7-4.dsc 2018-11-16 15:33 1.1K xephem_3.7.7.orig.tar.gz 2015-08-10 04:53 17M
 ChangeLog

06-11-2016
New debian version - 3.7.7-3 - Added from user/contrib support for ssl and "LRO" moon image
Compiled on Jessie

22-08-2015
 !!
 !! IMPORTANT 
 !!
New distributions (Debian Jessie, Trusty Tahr) has no lesstif* packages, so version 3.7.7-2 is linked to LGPL motif (libxm4, libmotif-dev).
Older releases with lesstif (e.g Wheezy, Pangolin) shloud install version 3.7.7-1

Added support for Raspberry Pi (armhf architecture). Compiled on Raspbian, (wheezy 7.8, linked to lesstif)

19-08-2015
New version debianized - 3.7.7.

21-01-2013
New package of new version - 3.7.6.
Compiled on squeeze. Checked on Debian squeeze/wheezy and Ubuntu LTS (Lucid/Precise)

11-08-2011
New package of new version - 3.7.5.
Becouse in "debian version" 3.7.5-RC11 is higher than 3.7.5 users
who have RC11 installed have to "downgrade number version" typing:
 apt-get install xephem=3.7.5-1
Compiled on squeeze. Checked on Debian squeeze and Ubuntu lucid

06-11-2010
Due to some bugfixes release 3.7.5-RC11 is now avaliable for debian-like users.
Compiled on lenny. Tested on Debian lenny/squeeze and Ubuntu lucid.
10-12-2010: It seems to be stable as normal release

15-07-2009
New release (3.7.4) from clearskyinstitute - now debianized
Compiled on lenny.

11-04-2008
New version 3.7.3
Debian lenny has corrected x11-common Conflicts: xephem (<= 3.4-5)
so its install clearly (no need to rename package).
Still compiled on etch.

16-02-2007
version 3.7.2
Debian users sholud install xephem-new instead of xephem.
Is the same but package name is different due to dependency problems 
with x11-common on Debian (x11-common has a xephem as a Conflict, 
probably old 3.4 xephem).

Compiled on etch